SuperProxy IPCOP LUSca

setelah di pantau dan stabil akhirnya gw coba share proxy LUSCA_HEAD buat IPCOP v 1.4.21.

featurenya

  • support for refresh_pattern store-stale (belum ada di squid-2.7 dan lusca original)
  • tambahan ignore-no-store,ignore-must-revalidate (belum ada di squid-2.7 dan lusca original),
  • patch loop untuk content video (akan muncul cacheHit dan looping terdetetect maka download ulang content yang sama akan di stop.
  • patch varry on, jika menggunakan default lusca / squid-2.7.x dengan menggunakan configurasi storeurl_rewrite_program, jangan di reboot servernya, jika reboot, file content dynamic akan menjadi miss

intinya sama kek Lusca_head yang di share bro siber wong source nya sama. gw cuma bantu compile sama modif biar bisa jalan di IPCOP.

ini screenshoot nya.

* addon ini memerlukan file dari advance proxy, jadi kalo mau make harus install advance proxy dolo.

#UPDATE:
update terbaru bisa di download disini lusca.head-ipcopv1.4.21-beta.tar.bz2
* fix patch untuk bugs yg di laporan bro xopal
* paket update ini juga sudah di tambahkan binary squidclient untuk melihat performa squid. contoh :

squidclient -h (ip_proxy_nya) -p (port_proxy_nya) mgr:info

download file tersebut kemudian upload ke mesin ipcop dengan winscp
login ke mesih icpop anda melalui putty
kemudian tar jxvf lusca.head-ipcopv1.4.21-beta.tar.bz2
cd lusca.head-ipcopv1.4.21-beta
./install

perhatikan step2 instalasi lanjutan setelah menjalankan ./install

* paket ini sudah termasuk tunning.conf dan storeurl-ipcop.pl jadi tinggal edit besar cache besar memory aja.

TAMBAHAN :

thanks buat bro dingo dan siber buat ngasih masukan sama reviewnya. buat user yang mau make addon ini harap config squid nya dibuat

memory_replacement_policy heap GDSF
cache_replacement_policy heap LFUDA

setting di panel admin ipcop

karena addon ini di compile support HEAP dan lru sebagai Removal policy, tapi pada prakteknya seperti yang di laporkan bro dingo hanya support HEAP. jadi harap config squid nya menggunakan option seperti yg di atas.

kalo masih error coba ketik squid -k parse terus paste di thread ini hasilnya. anggap ini thread jadi support lusca_head versi ipcop. thanks

New UPDATE :
http://ipcop-squid.googlecode.com/fi…0-beta.tar.bz2

download dan upload ke mesin ipcop anda

khusus update dari lusca ipcop versi lama ke versi baru hanya jalankan perintah ./update

untuk install baru perintah ./install

selamat menikmati hohoho

Iklan
Dipublikasi di Uncategorized | Meninggalkan komentar

PROXY dengan UBUNTU 10.10 64 BIT + LUSCA_HEAD-r14809

UBUNTU 10.10 64 BIT + LUSCA_HEAD-r14809

Paket yang Dibutuhkan : http://untuk-kamu.googlecode.com/fil…nt%20lusca.rar
Link Dw UBUNTU 10.10 64 bit http://ubuntu.pesat.net.id/releases/…rver-amd64.iso

Quote:
Bahan-bahan :
– Ubuntu 10.10 64 bit
– Ip proxy 192.168.3.1
– Gatewai 192.168.3.254
– Ip mikrotik ke arah proxy 192.168.3.254/24
– Ram 1 GB
– HDD Sata 250 GB

1. Partisi HDD

Quote:
Dari harddisk 250 Gb dibagi dg type partisi primary sebagai berikut:
1 gb ext4 /boot ( Flag Boot) jika Flag Boot masih off setelah pilihan on ABAIKAN SAJA
16 gb ext4 /
1.0 gb swap swap
sisanya gb ext4 /cache

2. Install Paket

Quote:
# sudo apt-get update
# sudo apt-get install squid
# sudo apt-get install squid squidclient squid-cgi
# sudo apt-get install gcc
# sudo apt-get install build-essential
# sudo apt-get install sharutils
# sudo apt-get install ccze
# sudo apt-get install libzip-dev
# sudo apt-get install automake1.9

3.Download Lusca

Quote:
download lusca lewat terminal ubuntu dengan perintah :
#”””wget http://untuk-kamu.googlecode.com/files/LUSCA_HEAD-r14809.tar.gz”””# 

lalu ekstrak dan masuk ke foldernya :

# tar xzvf LUSCA_HEAD-r14809.tar.gz
# cd LUSCA_HEAD-r14809/

@ patch dulo revalidate dgn cara : patch -p0 < imr.diff

ok..!! sekarang dimulai tahap compile nya :

cat /proc/cpuinfo : untuk mengetahui info cpu proxy nya

Link untuk mengetahui CHOST dan CFLAGS ;
# untuk AMD http://en.gentoo-wiki.com/wiki/Safe_Cflags/AMD
# untuk INTEL http://en.gentoo-wiki.com/wiki/Safe_Cflags/Intel

CHOST=”x86_64-pc-linux-gnu”
CFLAGS=”-march=nocona -O2 -pipe”

./configure –prefix=/usr –exec_prefix=/usr –bindir=/usr/sbin –sbindir=/usr/sbin –libexecdir=/usr/lib/squid –sysconfdir=/etc/squid \
–localstatedir=/var/spool/squid –datadir=/usr/share/squid –enable-async-io=24 –with-aufs-threads=24 –with-pthreads –enable-storeio=aufs \
–enable-linux-netfilter –enable-arp-acl –enable-epoll –enable-removal-policies=heap –with-aio –with-dl –enable-snmp \
–enable-delay-pools –enable-htcp –enable-cache-digests –disable-unlinkd –enable-large-cache-files –with-large-files \
–enable-err-languages=English –enable-default-err-language=English –with-maxfd=65536

selanjutnya, ketik perintah berikut di terminal ubuntu :

# make
# sudo make install

Quote:
Edit squid.conf 

agar perintah sudo /etc/init.d/squid stop jalan di ubuntu 10.10
#copy file squid yg di download tadi ke /etc/init.d/

jgn lupa di :
#sudo chmod +x /etc/init.d/squid

# stop dulu squidnya :
sudo /etc/init.d/squid stop

#paste file squid.conf, dan storeur.pl yg di download tadi kedalam folder /etc/squid —-> edit sesuai network juragan

4. Langkah selanjutnya

Code:
# Memberikan permission pada folder cache

chown proxy:proxy /cache
chmod 777 /cache
chown proxy:proxy /etc/squid/storeurl.pl
chmod 777 /etc/squid/storeurl.pl

# Membuat folder-folder swap/cache di dalam folder cache yang telah ditentukan dg perintah :

squid -f /etc/squid/squid.conf -z

# Restart squid
sudo /etc/init.d/squid restart 

Reboot CPU nya...
Dipublikasi di Uncategorized | Meninggalkan komentar

Cara Instal Smoothwall sebagai web proxy Mikrotik

Satu lagi kernel Linux yang bisa digunakan sebagai firewall, router dan sekaligus sebagai proxy squid. Seperti IPCop, dengan hardware sederhana / jadul sekelas Pentium 200 Mhz memory 128 Mb, bisa didongkrak menjadi sebuah firewall dan proxy yang cukup handal.
Smoothwall bisa difungsikan sebagai web proxy external Mikrotik, yang menurut beberapa orang kurang maksimal jika menggunakan wep proxy bawaan Mikrotik. Sehingga pengaturan bandhwidth kita tetap menggunakan Mikrotik dan untuk proxy transperant menggunakan Smoothwall yang difungsikan sebagai proxy.

Sebenarnya Smoothwall juga bisa difungsikan sebagai router dengan menggunakan 2 Lan ( Red + Green), dan bisa dikombinasikan untuk hotspot dengan wifi memanfaatlan interface orange dan purple. Namun sekarang kita coba, memungsikan Smoothwall sebagai web proxy external Mikrotik.
Jangan terbayang linux yang sulit dan rumit dalam membangun sebuah proxy dengan Smoothwall ini, karena interface yang familiar seperti windows, dengan GUI (Graphical User Interface ) berbasis Web mempermudah dalam menginstal dan mengatur konfigurasi firewall, router dan proxy untuk keperluan kantor atau warnet yang membutuhkan sharing internet dengan bandwith yang pas-pasan. Karena sebesar apapun badhwidth yang kita miliki, tanpa pengaturan dan pembagian yang akurat, akan sia-sia dan tidak bisa dimanfaatkan secara maksimal.

Yang perlu kita persiapkan untuk membangun sebuah proxy Smoothwall adalah :
  1. Komputer minimal Pentium 200 memory 128 Mb Harddisk 5 GB ( lebih tinggi lebih bagus )
  2. Minimal 2 buah LAN Card ( Red dan Green )
  3. 1 buah kabel UTP CrossOver
  4. CD ISO Smoothwall 3.0 yang bisa di unduh disini. Cara membuat CD ISO bisa lihat disini.
  5. Dokumen petunjuk instalasi Smoothwall bisa lihat disini.
  6. Screenshots Smoothwall bisa ditengok disini.
  7. Advanced Proxy yang bisa disedot disini. Pentunjuknya disini.
  8. Screenshots Advanced Proxy tengok disini.
Setelah kita persiapkan semua hardware dan software pendukung untuk membangun Smoothwall, termasuk membaca petunjuk instalasinya maka langkah selanjutnya adalah menggabungkan /memfungsikan Smoothwall sebagai Web Proxy External Mikrotik.
Ada beberapa hal penting dalam ini :
Topologi Proxy Smoothwall

  • Karena Smoothwall akan difungsikan sebagai Proxy ( karena Proxy di Mikrotik kurang maksimal ) maka kita memilih Green + Red. ( Orange dan Purple tidak kita gunakan, karena untuk Wireless/Hotspot kita menggunakan interface di Mikrotik ).
  • Meskipun interface Red tidak kita fungsikan, tetap kita pasang dan kita konfigurasi jaringan dengan IP Address yang berbeda dengan interface Green. Interface Green IP nya kita samakan dengan IP dari Mikrotik. Misal : interface proxy pada Mikrotik 192.168.2.1 maka IP Green 192.168.2.xx. IP Red kita beri IP misal 192.168.3.1 ( tidak dihubungkan apapun ) karena menggunakan kabel CrossOver, dari Green ke Mikrotik.
  • Gateway pada Smoothwall kita ambil IP interface Mikrotik ( 192.168.2.1) demikian juga untuk Primary DNS. Untuk Secondary DNS bisa kita ambilkan IP Interface yang tersambung dengan modem ( 192.168.1.1).
  • Port proxy sebaiknya kita rubah. Default port Smoothwall adalah 800. Kita ganti portnya misal 2020.

Smoothwall yang sudah selesai kita install, selanjutnya perlu kita atur konfigurasinnya dengan mengakses di web.

remote access  ssh

  • Beri tanda centang/cawang pada Enabled on Green
  • Beri tanda centang/cawang pada Transparent on Green
  • Rubah port default 800 menjadi 2020 (seperti contoh)

setting proxy

  • Dan pada NAT di Mikrotik tambahkan :

chain=dstnat src-address=192.168.2.0/24 protocol=tcp dst-port=80
action=dst-nat to-addresses=192.168.2.100 to-ports=2020

chain=dstnat src-address=192.168.2.0/24 protocol=tcp dst-port=8080 action=dst-nat to-addresses=192.168.2.100 to-ports=2020

chain=dstnat src-address=192.168.2.0/24 protocol=tcp dst-port=3128 action=dst-nat to-addresses=192.168.2.100 to-ports=2020

chain=dstnat protocol=tcp dst-port=81 action=dst-nat to-addresses=192.168.2.100 to-ports=81

chain=dstnat protocol=tcp dst-port=441 action=dst-nat to-addresses=192.168.2.100 to-ports=441

chain=dstnat protocol=tcp dst-port=445 action=dst-nat to-addresses=192.168.2.100 to-ports=445

Keterangan : 192.168.2.100 adalah IP GREEN 2020 adalah PORT SMOOTHWALL

Dengan melakukan setting diatas, jika semua sudah benar maka Smoothwall yang difungsikan sebagai Web Proxy External Mikrotik bisa berjalan, dan berfungsi sebagai transperant. Ini dapat dicoba dengan melakukan browsing di client, jika berjalan dengan lancar maka setingan sudah benar. Jika di client masih belum bisa browsing perlu diperiksa kembali setingan di Smoothwall atau di NAT Mikrotik.

Langkah pertama Disable dulu, NAT Mikrotik diatas. Coba browsing kembali. Jika bisa browsing, berarti kesalahan ada pada Smoothwall. Cek lagi konfigurasinya, jika perlu restart dulu Smoothwall. Nah kemudian Enable NAT, dan coba browsing. Jika sudah bisa browsing artinya semua sudah oke.

Oh ya, jika kita menggunakan Mikrotik untuk Hotspot pada interface dengan IP address 192.168.4.1 maka dalam Hotspot User Profiles harus kita centang Transperant Proxy dan juga pada smoothwall kita masukan subnet IP HOtspot tersebut.

Proxy Smoothwall standard sudah bisa jalankan berdampingan dengan Mikrotik, namun kita bisa menggunakan yang Advanced Proxy untuk pengaturan yang lebih kompleks. Cara install Advanced Proxy bisa dilihat di postingan ini.

Dipublikasi di Uncategorized | Meninggalkan komentar

Squid ZPH (Zero Penalty Hit)

Squid ZPH

Dipublikasi di Uncategorized | Meninggalkan komentar

Report Web Proxy ClearOS 5.2

 

Dipublikasi di Uncategorized | Meninggalkan komentar

.:: Mikrotik & External Web Proxy ::.

Panduan setting MikroTik + External Web Proxy dengan ClearOS 5.2

— Buat Mangle (Keperluan Bandwidth Manager)

/ip firewall mangle add chain=postrouting content=”X-Cache: HIT” protocol=tcp action=mark-connection new-connection-mark=proxy_con comment=”PROXY-EXT” passthrough=yes ;
/ip firewall mangle add chain=postrouting connection-mark=proxy_con comment=”PROXY-EXT” action=mark-packet new-packet-mark=proxy-down passthrough=no ;

/ip firewall mangle add chain=prerouting src-address=192.168.0.200 in-interface=lan action=mark-packet new-packet-mark=billing-up comment=BILLING passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.200 out-interface=lan action=mark-packet new-packet-mark=billing-browse connection-bytes=0-250000 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.200 out-interface=lan action=mark-packet new-packet-mark=billing-limit connection-bytes=250001-4294967295 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.200 out-interface=lan action=mark-packet new-packet-mark=billing-game passthrough=no ;

:for i from=1 to=9 do={
/ip firewall mangle add chain=prerouting src-address=(“192.168.0.20” . $i) in-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-up”) comment=(“PC” . $i ) passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.20” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-browse”) connection-bytes=0-250000 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.20” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-limit”) connection-bytes=250001-4294967295 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.20” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-game”) passthrough=no ;
}

:for i from=10 to=40 do={
/ip firewall mangle add chain=prerouting src-address=(“192.168.0.2” . $i) in-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-up”) comment=(“PC” . $i ) passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.2” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-browse”) connection-bytes=0-250000 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.2” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-limit”) connection-bytes=250001-4294967295 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=(“192.168.0.2” . $i) out-interface=lan action=mark-packet new-packet-mark=(“pc” . $i . “-game”) passthrough=no ;
}

/ip firewall mangle add chain=prerouting src-address=192.168.0.250 in-interface=lan action=mark-packet new-packet-mark=proxy-up comment=PROXY passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.250 out-interface=lan action=mark-packet new-packet-mark=proxy-down passthrough=no ;

/ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 in-interface=lan action=mark-packet new-packet-mark=lan-up comment=LAN passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.0/24 out-interface=lan action=mark-packet new-packet-mark=lan-browse connection-bytes=0-250000 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.0/24 out-interface=lan action=mark-packet new-packet-mark=lan-limit connection-bytes=250001-4294967295 protocol=tcp passthrough=no ;
/ip firewall mangle add chain=postrouting  dst-address=192.168.0.0/24 out-interface=lan action=mark-packet new-packet-mark=lan-game passthrough=no ;

Baca lebih lanjut

Dipublikasi di Uncategorized | Meninggalkan komentar

Seting Web Proxy di Mikrotik 2.9.27

1. Login ke Mikrotik via WinBox
2. Pilih Menu IP kemudian Pilih Web Proxy


3. Klik menu Settings
4. Buat setting seperti ini


5. Kemudian Klik Enable
6. Untuk memblokir situs klik tanda PLUS


7. Pilih menua IP kemudian pilih Firewall


8. Pilih tab NAT


9. Add NAT Rule
10. Pada kolom In. Interface isikan ether ang kamu pake
11. Pilih tab Action
12. Buat seperti gambar kemudian klik Apply dan OK
Dah selesai donk
Sekarang silahkan di coba proxynya
Semoga berhasil

Dipublikasi di Uncategorized | Meninggalkan komentar